X Używamy plików cookie i zbieramy dane m.in. w celach statystycznych i personalizacji reklam. Jeśli nie wyrażasz na to zgody, więcej informacji i instrukcje znajdziesz » tutaj «.

Numer: 15767
Przesłano:

Zapoznanie oraz ćwiczenia z funkcją Powtórz w programie Logo Komeniusz - konspekt lekcji informatyki

Konspekt lekcji informatyki w klasie V szkoły podstawowej

TEMAT: Zapoznanie oraz ćwiczenia z funkcją Powtórz w programie Logo Komeniusz.

Czas trwania lekcji: 45 minut
Cele operacyjne:
• uczeń potrafi poprawnie rozpocząć oraz zacząć pracę z programem Logo Komeniusz,
• uczeń zna komendy podstawowe języka Logo Komeniusz oraz potrafi je zastosować;
• uczeń poznaje nową komendę Powtórz;
• uczeń potrafi narysować różne figury geometryczne za pomocą komendy Powtórz;
• uczniowie pracują indywidualnie lub w parach na lekcji.
Metody pracy
• pogadanka wraz z wykonaniem ćwiczeń pomocniczych;
• praca indywidualna lub w parach.
Środki dydaktyczne
• zestaw komputerowy wraz z oprogramowaniem Logo Komeniusz;
• zeszyt.
Przebieg lekcji
- podanie tematu lekcji i uświadomienie uczniom celów lekcji;
- włączenie komputerów oraz uruchomienie programu Logo Komeniusz;
- wykonanie ćwiczeń pomocniczych (na podstawie komend do narysowania kwadratu oraz prostokąta wytłumaczenie działania komendy Powtórz);
- przystąpienie uczniów do pracy, czyli wykonywanie ćwiczeń indywidualnie lub w parach – rysowanie różnych figur z zastosowaniem komendy Powtórz;
- podsumowanie – napisanie rozwiązań na tablicy, które zostaną nagrodzone przez nauczyciela oceną.


Ćwiczenie pomocnicze.
Polecenie:

Napisać komendy do narysowania kwadratu o boku 100. Napisać je w jednej linii.
Następnie napisać także w jednej linii komendy do narysowania prostokąta o bokach 40 i 80.
Rozwiązanie:
Komendy do narysowania kwadratu:
np 100 pw 90 np 100 pw 90 np 100 pw 90 np 100 pw 90

Uczniowie zauważają, że komendy się powtarzają czterokrotnie, więc wykorzystują komendę Powtórz do narysowania kwadratu.
Powtórz 4[np 100 pw 90]
Komendy do narysowania prostokąta:
np 40 pw 90 np 80 pw 90 np 40 pw 90 np 80 pw 90

Komendy się powtarzają dwukrotnie.
Powtórz 2[np 40 pw 90 np 80 pw 90]

Ćwiczenia do wykonania indywidualnego lub w parach.
Polecenie:
Narysuj za pomocą komendy Powtórz następujące figury:

O nas | Reklama | Kontakt
Redakcja serwisu nie ponosi odpowiedzialności za treść publikacji, ogłoszeń oraz reklam.
Copyright © 2002-2019 Edux.pl
| Polityka prywatności | Wszystkie prawa zastrzeżone.
Prawa autorskie do publikacji posiadają autorzy tekstów.